%%ItemTitle%%

contentXXL Send comments on this topic.
ContentXXL.Modules.Common Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
ContentModuleDesktop | This class handles how to apply module settings and display objects in content modules (base class for the desktop.ascx or corresponding desktopsrc files)

Delegates

Delegate | Description
AfterCreateDetailViewEventHandler |
AfterCreateListViewEventHandler |
AfterSetLinksEventHandler |
BeforeContainerDataBindEventHandler |
BeforeCreateDetailViewEventHandler |
BeforeCreateListViewEventHandler |
BeforeSetLinksEventHandler |
SetLinkItemEventHandler |

See Also

Reference

contentXXL Assembly

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

ContentModuleDesktop Class
See Also Members
[image]
ContentXXL.Modules.Common Namespace : ContentModuleDesktop Class

This class handles how to apply module settings and display objects in content modules (base class for the desktop.ascx or corresponding desktopsrc files)

Syntax

Visual Basic (Declaration)
Public MustInherit Class ContentModuleDesktop
   Inherits ContentModule
C#
public abstract class ContentModuleDesktop : ContentModule

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Members
ContentXXL.Modules.Common Namespace


%%PageItemTitle%% $$Members$$

ContentModuleDesktop Class Members
See Also Fields Properties Methods Events
[image]
ContentXXL.Modules.Common Namespace : ContentModuleDesktop Class

The following tables list the members exposed by ContentModuleDesktop.

Public Fields

 | Name | Description
Public Field | cdvBigView |
Public Field | cdvFooter |
Public Field | cdvHeader |
Public Field | cdvSmallView |
Top

Protected Fields

 | Name | Description
Protected Field | CustomDataFilterCustomization |
Protected Field | DescriptionPages | Array containing paged object descriptions.
Top

Public Properties

 | Name | Description
Public Property | AutomaticallyRelatedMaxCount | Returns the maximum amount of automatically related (category based) objects (setting for related modules).
Public Property | BigColumnsCount | Returns the number of columns to display the modules big preview.
Public Property | BigItemAltTemplate | Gets the alternate item template for the big preview.
Public Property | BigItemsCount | Returns the number of objects to be displayed within the modules big preview.
Public Property | BigItemTemplate | Gets the item template for the big preview.
Public Property | CategoryParameter | Gets the categories parameter from context.items.
Public Property | CustomSetting | Returns a collection of the module custom settings.
Public Property | DetailPrintTemplate | Gets the print template.
Public Property | DetailViewTemplate | Gets the detail view template.
Public Property | FooterTemplate | Gets the footer template.
Public Property | HeaderTemplate | Gets the header template.
Public Property | IsDetailViewTableMustBeCached |
Public Property | IsInFirstItemViewMode | Gets a value indicating if the module is in feature mode.
Public Property | IsInRotationMode | Gets a value indicating if the module is in rotation mode.
Public Property | IsInTeaserMode | Gets a value indicating if the module is in teaser mode.
Public Property | objectcount | Returns the number of objects that should be shown inside the module.
Public Property | PagingSize | Returns the number of objects to be displayed on one page.
Public Property | RelatedAltItemTemplate | Gets the related object alternate item template (setting for related modules).
Public Property | RelatedItemsCount | Returns the number of related items.
Public Property | RelatedItemTemplate | Gets the related object item template (setting for related modules).
Public Property | RelationTypeFilter | Returns the selected relation type (setting for related modules).
Public Property | Settings | Overridden. Returns a hashtable containig the module settings.
Public Property | SmallColumnsCount | Returns the number of columns to display the modules small preview.
Public Property | SmallItemAltTemplate | Gets the alternate item template for the small preview.
Public Property | SmallItemsCount | Returns the number of objects to be displayed within the modules small preview.
Public Property | SmallItemTemplate | Gets the item template for the small preview.
Public Property | TypeFilter | Returns the selected object type (setting for related modules).
Public Property | UseCategoriesInUrlAND | Gets a value indicating to if related objects regarding multiple categories (AND/conjunction) passed in URL are to be shown (setting for related modules).
Public Property | UseCategoriesInUrlOR | Gets a value indicating if related objects regarding multiple categories (OR/disjunction) passed in URL are to be shown (setting for related modules).
Public Property | UseCategoryNavigation | Gets a value indicating if related objects regarding the category passed in URL are to be shown (setting for related modules).
Public Property | UseDefiniedCategories | Gets a value indicating if related objects regarding the specified categories are to be shown (setting for related modules).
Public Property | UseTypeFilter | Gets a value indicating if an object type filter is to be applied (setting for related modules).
Top

Protected Properties

 | Name | Description
Protected Property | DetailViewItemID | Returns the itemid of the current object in detail view.
Protected Property | IsInDetailView | Gets a value indicating if the module is in detail view of an object.
Protected Property | IsRelatedModule | Gets a value indicating if the module is a related module.
Protected Property | MoreLinkModuleID | Gets the teaser taget moduleid if the module is in teaser mode, otherwise it returns the current moduleid.
Protected Property | MoreLinkTabID | Gets the tabid for the teaser taget module if the module is in teaser mode, otherwise it returns the current tabid.
Protected Property | ObjectName | Gets the name of the object.
Protected Property | RequestedPage | Returns the number of the requested page when a paging command is present in the URL.
Top

Public Methods

 | Name | Description
Public Method | CreateBigView | Binds the datasource to the big item and the big item alternate template.
Public Method | CreateSmallView | Binds the datasource to the small item and the small item alternate template.
static (Shared in Visual Basic) | DissolvingRAID | Parses the input String and replaces the resourceimage.aspx?raid= with the absolute path of the file if it exists.
Public Method | GetPagingLink | Gets a link for paging.
static (Shared in Visual Basic) | GetResourceAssignTable | Overloaded. Gets all resources assigned to objects published in one module.
Public Method | GetResourceUrl | Gets the call of the resourceimage.aspx or a resourceid or a resourceassignid.
Public Method | SetModuleTitleText | Sets the module title and links for the admin popup menu (not for related modules).
Top

Protected Methods

 | Name | Description
Protected Method | BindContentDataView | Sets the item template and alternate item template for the specified container.
Protected Method | CreateCategoryNavigationView | Creates the view for a related module if usecategorynavigation is set to true.(related objects regarding the category passed in URL are shown).
Protected Method | CreateDetailView | Overloaded. Creates the detail view for the specified object.
Protected Method | CreateEditView | Overloaded.
Protected Method | CreateFirstItemView | Creates the view when the module is in feature mode.
Protected Method | CreateListView | Creates the list view.
Protected Method | CreateModuleView | Overloaded.
Protected Method | CreateNewObject | Creates a new object.
Protected Method | CreatePagerDataTable | Splits the object description into single pages and stores them in the field DescriptionPages).
Protected Method | CreateRelatedByCategoryView | Creates the view for a related module if UseCategoryNavigation, UseCategoriesInUrlOR and UseCategoriesInUrlAND are set to false (objects related by category are shown).
Protected Method | CreateRelatedManuallyView | Creates the view for a related module if UseCategoryNavigation, UseCategoriesInUrlOR and UseCategoriesInUrlAND are set to false (manually related objects are shown).
Protected Method | CreateRelatedView | Creates the view for a related module.
Protected Method | FillNoResultDataTable | Fills the datatable which is bound to the noresult template.
Protected Method | GetDetailViewTable | Returns a datatable with the detail view data.
Protected Method | GetDetailViewTableForPreview | Returns a datatable with the detail view data for a preview within the sitemanager.
Protected Method | GetListViewTable | Returns the list view data table.
Protected Method | InstantinateNewObject | Creates a new object and sets the fields FilterStandardLanguage: True | False according to current module settings IsInPresentationLayer: True
Protected Method | ResetPaging | Resets the paging.
Protected Method | SetDetailViewPagingInfo | Sets the detail view paging info for the specified object.
Protected Method | SetLinks | Sets the links (morelink, tellafriendlink ...) in the specified datatable.
Protected Method | SetListViewPagingInfo | Returns a datatable with paging information.
Protected Method | SetModuleVisibility | Sets the visibility of the module.
Protected Method | SetRotationModeData | Sets the object which is to be shown when the module is in rotation mode.
Top

Public Events

 | Name | Description
Public Event | AfterCreateDetailView | Occurs after the detail view is created.
Public Event | AfterCreateListView | Occurs after the list view is created.
Public Event | AfterSetLinks | Occurs after links are set (e.g. morelink).
Public Event | BeforeContainerDataBind | Occurs before data are bound to container.
Public Event | BeforeCreateDetailView | Occurs before the detail view is created.
Public Event | BeforeCreateListView | Occurs before the list view is created.
Public Event | BeforeSetLinks | Occurs before links are set (e.g. morelink).
Public Event | SetLinkItem | Occurs after all links for one item are set.
Top

See Also

Reference

ContentModuleDesktop Class
ContentXXL.Modules.Common Namespace


%%PageItemTitle%% $$Methods$$

ContentModuleDesktop Class Methods
See Also
[image]
ContentXXL.Modules.Common Namespace : ContentModuleDesktop Class

For a list of all members of this type, see ContentModuleDesktop members.

Public Methods

 | Name | Description
Public Method | CreateBigView | Binds the datasource to the big item and the big item alternate template.
Public Method | CreateSmallView | Binds the datasource to the small item and the small item alternate template.
static (Shared in Visual Basic) | DissolvingRAID | Parses the input String and replaces the resourceimage.aspx?raid= with the absolute path of the file if it exists.
Public Method | GetPagingLink | Gets a link for paging.
static (Shared in Visual Basic) | GetResourceAssignTable | Overloaded. Gets all resources assigned to objects published in one module.
Public Method | GetResourceUrl | Gets the call of the resourceimage.aspx or a resourceid or a resourceassignid.
Public Method | SetModuleTitleText | Sets the module title and links for the admin popup menu (not for related modules).
Top

Protected Methods

 | Name | Description
Protected Method | BindContentDataView | Sets the item template and alternate item template for the specified container.
Protected Method | CreateCategoryNavigationView | Creates the view for a related module if usecategorynavigation is set to true.(related objects regarding the category passed in URL are shown).
Protected Method | CreateDetailView | Overloaded. Creates the detail view for the specified object.
Protected Method | CreateEditView | Overloaded.
Protected Method | CreateFirstItemView | Creates the view when the module is in feature mode.
Protected Method | CreateListView | Creates the list view.
Protected Method | CreateModuleView | Overloaded.
Protected Method | CreateNewObject | Creates a new object.
Protected Method | CreatePagerDataTable | Splits the object description into single pages and stores them in the field DescriptionPages).
Protected Method | CreateRelatedByCategoryView | Creates the view for a related module if UseCategoryNavigation, UseCategoriesInUrlOR and UseCategoriesInUrlAND are set to false (objects related by category are shown).
Protected Method | CreateRelatedManuallyView | Creates the view for a related module if UseCategoryNavigation, UseCategoriesInUrlOR and UseCategoriesInUrlAND are set to false (manually related objects are shown).
Protected Method | CreateRelatedView | Creates the view for a related module.
Protected Method | FillNoResultDataTable | Fills the datatable which is bound to the noresult template.
Protected Method | GetDetailViewTable | Returns a datatable with the detail view data.
Protected Method | GetDetailViewTableForPreview | Returns a datatable with the detail view data for a preview within the sitemanager.
Protected Method | GetListViewTable | Returns the list view data table.
Protected Method | InstantinateNewObject | Creates a new object and sets the fields FilterStandardLanguage: True | False according to current module settings IsInPresentationLayer: True
Protected Method | ResetPaging | Resets the paging.
Protected Method | SetDetailViewPagingInfo | Sets the detail view paging info for the specified object.
Protected Method | SetLinks | Sets the links (morelink, tellafriendlink ...) in the specified datatable.
Protected Method | SetListViewPagingInfo | Returns a datatable with paging information.
Protected Method | SetModuleVisibility | Sets the visibility of the module.
Protected Method | SetRotationModeData | Sets the object which is to be shown when the module is in rotation mode.
Top

See Also

Reference

ContentModuleDesktop Class
ContentXXL.Modules.Common Namespace


%%PageItemTitle%%

BindContentDataView Method
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : BindContentDataView Method

container
ContainerDataView for which the templates are to be set.
itemTemplatePath
Path to the item template.
itemAltTemplatePath
Path to the alternate item template.
Sets the item template and alternate item template for the specified container.

Syntax

Visual Basic (Declaration)
Protected Sub BindContentDataView( _
   ByVal container As ContainerDataView, _
   ByVal itemTemplatePath As String, _
   ByVal itemAltTemplatePath As String _
)
C#
protected void BindContentDataView(
   ContainerDataView container,
   string itemTemplatePath,
   string itemAltTemplatePath
)

Parameters

container
ContainerDataView for which the templates are to be set.
itemTemplatePath
Path to the item template.
itemAltTemplatePath
Path to the alternate item template.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members


%%PageItemTitle%%

CreateBigView Method
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : CreateBigView Method

listViewTable
Datasource table.
Binds the datasource to the big item and the big item alternate template.

Syntax

Visual Basic (Declaration)
Public Overridable Sub CreateBigView( _
   ByRef listViewTable As DataTable _
)
C#
public virtual void CreateBigView(
   ref DataTable listViewTable
)

Parameters

listViewTable
Datasource table.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

CreateCategoryNavigationView Method
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : CreateCategoryNavigationView Method

Creates the view for a related module if usecategorynavigation is set to true.(related objects regarding the category passed in URL are shown).

Syntax

Visual Basic (Declaration)
Protected Overridable Sub CreateCategoryNavigationView()
C#
protected virtual void CreateCategoryNavigationView()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

CreateDetailView Method
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : CreateDetailView Method

Creates the detail view for the specified object.

Overload List

Overload | Description
CreateDetailView(Int32) | Creates the detail view for the specified object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

CreateDetailView(Int32) Method
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class > CreateDetailView Method : CreateDetailView(Int32) Method

itemID
The object itemid.
Creates the detail view for the specified object.

Syntax

Visual Basic (Declaration)
Overloads Protected Overridable Sub CreateDetailView( _
   ByVal itemID As Integer _
)
C#
protected virtual void CreateDetailView(
   int itemID
)

Parameters

itemID
The object itemid.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members
Overload List


%%PageItemTitle%%

CreateEditView Method
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : CreateEditView Method

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

CreateFirstItemView Method
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : CreateFirstItemView Method

Creates the view when the module is in feature mode.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub CreateFirstItemView()
C#
protected virtual void CreateFirstItemView()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

CreateListView Method
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : CreateListView Method

Creates the list view.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub CreateListView()
C#
protected virtual void CreateListView()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

CreateModuleView Method
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : CreateModuleView Method

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

CreateNewObject Method
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : CreateNewObject Method

Creates a new object.

Syntax

Visual Basic (Declaration)
Protected MustOverride Function CreateNewObject() As ContentObjectBase
C#
protected abstract ContentObjectBase CreateNewObject()

Return Value

The object

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

CreatePagerDataTable Method
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : CreatePagerDataTable Method

description
The object description (WYSIWYG).
Splits the object description into single pages and stores them in the field DescriptionPages).

Syntax

Visual Basic (Declaration)
Protected Overridable Sub CreatePagerDataTable( _
   ByVal description As String _
)
C#
protected virtual void CreatePagerDataTable(
   string description
)

Parameters

description
The object description (WYSIWYG).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

CreateRelatedByCategoryView Method
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : CreateRelatedByCategoryView Method

baseGlobalID
Globalid of the base object for the relation.

Creates the view for a related module if UseCategoryNavigation, UseCategoriesInUrlOR and UseCategoriesInUrlAND are set to false
(objects related by category are shown).

Syntax

Visual Basic (Declaration)
Protected Overridable Sub CreateRelatedByCategoryView( _
   ByVal baseGlobalID As String _
)
C#
protected virtual void CreateRelatedByCategoryView(
   string baseGlobalID
)

Parameters

baseGlobalID
Globalid of the base object for the relation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

CreateRelatedManuallyView Method
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : CreateRelatedManuallyView Method

baseGlobalID
Globalid of the base object for the relation.

Creates the view for a related module if UseCategoryNavigation, UseCategoriesInUrlOR and UseCategoriesInUrlAND are set to false
(manually related objects are shown).

Syntax

Visual Basic (Declaration)
Protected Overridable Sub CreateRelatedManuallyView( _
   ByVal baseGlobalID As String _
)
C#
protected virtual void CreateRelatedManuallyView(
   string baseGlobalID
)

Parameters

baseGlobalID
Globalid of the base object for the relation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

CreateRelatedView Method
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : CreateRelatedView Method

Creates the view for a related module.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub CreateRelatedView()
C#
protected virtual void CreateRelatedView()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

CreateSmallView Method
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : CreateSmallView Method

listViewTable
Datasource table.
Binds the datasource to the small item and the small item alternate template.

Syntax

Visual Basic (Declaration)
Public Overridable Sub CreateSmallView( _
   ByRef listViewTable As DataTable _
)
C#
public virtual void CreateSmallView(
   ref DataTable listViewTable
)

Parameters

listViewTable
Datasource table.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

DissolvingRAID Method
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : DissolvingRAID Method

inputStr
The input String
Parses the input String and replaces the resourceimage.aspx?raid= with the absolute path of the file if it exists.

Syntax

Visual Basic (Declaration)
Public Shared Function DissolvingRAID( _
   ByVal inputStr As String _
) As String
C#
public static string DissolvingRAID(
   string inputStr
)

Parameters

inputStr
The input String

Return Value

The paresed and replaced String

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

FillNoResultDataTable Method
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : FillNoResultDataTable Method

DT
The DT.
Fills the datatable which is bound to the noresult template.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub FillNoResultDataTable( _
   ByRef DT As DataTable _
)
C#
protected virtual void FillNoResultDataTable(
   ref DataTable DT
)

Parameters

DT
The DT.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

GetDetailViewTable Method
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : GetDetailViewTable Method

itemID
The object itemid.
Returns a datatable with the detail view data.

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetDetailViewTable( _
   ByVal itemID As Integer _
) As DataTable
C#
protected virtual DataTable GetDetailViewTable(
   int itemID
)

Parameters

itemID
The object itemid.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

GetDetailViewTableForPreview Method
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : GetDetailViewTableForPreview Method

itemID
The object itemid.
Returns a datatable with the detail view data for a preview within the sitemanager.

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetDetailViewTableForPreview( _
   ByVal itemID As Integer _
) As DataTable
C#
protected virtual DataTable GetDetailViewTableForPreview(
   int itemID
)

Parameters

itemID
The object itemid.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

GetListViewTable Method
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : GetListViewTable Method

Returns the list view data table.

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetListViewTable() As DataTable
C#
protected virtual DataTable GetListViewTable()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

GetPagingLink Method
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : GetPagingLink Method

lRequestedPage
Page number of the requested page (_page-lRequestedPage).
lTotalPages
Total number of pages.
getEmpty
True if empty string is to be returned, otherwise false.
Gets a link for paging.

Syntax

Visual Basic (Declaration)
Public Function GetPagingLink( _
   ByVal lRequestedPage As Integer, _
   ByVal lTotalPages As Integer, _
   ByVal getEmpty As Boolean _
) As Object
C#
public object GetPagingLink(
   int lRequestedPage,
   int lTotalPages,
   bool getEmpty
)

Parameters

lRequestedPage
Page number of the requested page (_page-lRequestedPage).
lTotalPages
Total number of pages.
getEmpty
True if empty string is to be returned, otherwise false.

Return Value

relative URL linking to the requested page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

GetResourceAssignTable Method
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : GetResourceAssignTable Method

Gets all resources assigned to objects published in one module.

Overload List

Overload | Description
GetResourceAssignTable(Int32) | Gets all resources assigned to objects published in one module.
GetResourceAssignTable() | Gets all resources assigned to objects in all portals.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

GetResourceAssignTable(Int32) Method
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class > GetResourceAssignTable Method : GetResourceAssignTable(Int32) Method

moduleID
The moduleID of the specified module.
Gets all resources assigned to objects published in one module.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function GetResourceAssignTable( _
   ByVal moduleID As Integer _
) As HybridDictionary
C#
public static HybridDictionary GetResourceAssignTable(
   int moduleID
)

Parameters

moduleID
The moduleID of the specified module.

Return Value

List containing assignid as key and resource URL as value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members
Overload List


%%PageItemTitle%%

GetResourceAssignTable() Method
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class > GetResourceAssignTable Method : GetResourceAssignTable() Method

Gets all resources assigned to objects in all portals.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function GetResourceAssignTable() As HybridDictionary
C#
public static HybridDictionary GetResourceAssignTable()

Return Value

List containing assignid as key and resource URL as value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members
Overload List


%%PageItemTitle%%

GetResourceUrl Method
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : GetResourceUrl Method

lResourceID
resourceid (value < 0) or resourceassignid (value > 0) of the resource.
Gets the call of the resourceimage.aspx or a resourceid or a resourceassignid.

Syntax

Visual Basic (Declaration)
Public Function GetResourceUrl( _
   ByVal lResourceID As Integer _
) As Object
C#
public object GetResourceUrl(
   int lResourceID
)

Parameters

lResourceID
resourceid (value < 0) or resourceassignid (value > 0) of the resource.

Return Value

string resourceimage.aspx?raid=lResourceID if lResourceid > 0, otherwise

resourceimage.aspx?rid=lResourceID

Example

GetResourceURL(5) returns resourceimage.aspx?raid=5

GetResourceURL(-5) returns resourceimage.aspx?rid=5

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

InstantinateNewObject Method
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : InstantinateNewObject Method

Creates a new object and sets the fields FilterStandardLanguage: True | False according to current module settings IsInPresentationLayer: True

Syntax

Visual Basic (Declaration)
Protected Overridable Function InstantinateNewObject() As Object
C#
protected virtual object InstantinateNewObject()

Return Value

The object

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

ResetPaging Method
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : ResetPaging Method

Resets the paging.

Syntax

Visual Basic (Declaration)
Protected Sub ResetPaging()
C#
protected void ResetPaging()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

SetDetailViewPagingInfo Method
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : SetDetailViewPagingInfo Method

itemID
The object itemid.
Sets the detail view paging info for the specified object.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetDetailViewPagingInfo( _
   ByVal itemID As Integer _
)
C#
protected virtual void SetDetailViewPagingInfo(
   int itemID
)

Parameters

itemID
The object itemid.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

SetLinks Method
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : SetLinks Method

moduleID
Moduleid to be used for link generation.
tabID
Tabid to be used for link generation.
table
Datatable to be modified.
setEditLink
If set to true, an editlink is generated, otherwise not (set to empty string).
setMoreLink
If set to true, a morelink is generated, otherwise not (set to empty string).
Sets the links (morelink, tellafriendlink ...) in the specified datatable.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetLinks( _
   ByVal moduleID As Integer, _
   ByVal tabID As Integer, _
   ByVal table As DataTable, _
   ByVal setEditLink As Boolean, _
   ByVal setMoreLink As Boolean _
)
C#
protected virtual void SetLinks(
   int moduleID,
   int tabID,
   DataTable table,
   bool setEditLink,
   bool setMoreLink
)

Parameters

moduleID
Moduleid to be used for link generation.
tabID
Tabid to be used for link generation.
table
Datatable to be modified.
setEditLink
If set to true, an editlink is generated, otherwise not (set to empty string).
setMoreLink
If set to true, a morelink is generated, otherwise not (set to empty string).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

SetListViewPagingInfo Method
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : SetListViewPagingInfo Method

completeListViewTable
Returns a datatable with paging information.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetListViewPagingInfo( _
   ByRef completeListViewTable As DataTable _
)
C#
protected virtual void SetListViewPagingInfo(
   ref DataTable completeListViewTable
)

Parameters

completeListViewTable

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

SetModuleTitleText Method
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : SetModuleTitleText Method

Sets the module title and links for the admin popup menu (not for related modules).

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetModuleTitleText()
C#
public virtual void SetModuleTitleText()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

SetModuleVisibility Method
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : SetModuleVisibility Method

Sets the visibility of the module.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetModuleVisibility()
C#
protected virtual void SetModuleVisibility()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

SetRotationModeData Method
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : SetRotationModeData Method

completeDataTable
Datatable with all objects.
Sets the object which is to be shown when the module is in rotation mode.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetRotationModeData( _
   ByRef completeDataTable As DataTable _
)
C#
protected virtual void SetRotationModeData(
   ref DataTable completeDataTable
)

Parameters

completeDataTable
Datatable with all objects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%% $$Properties$$

ContentModuleDesktop Class Properties
[image]
ContentXXL.Modules.Common Namespace : ContentModuleDesktop Class

For a list of all members of this type, see ContentModuleDesktop members.

Public Properties

 | Name | Description
Public Property | AutomaticallyRelatedMaxCount | Returns the maximum amount of automatically related (category based) objects (setting for related modules).
Public Property | BigColumnsCount | Returns the number of columns to display the modules big preview.
Public Property | BigItemAltTemplate | Gets the alternate item template for the big preview.
Public Property | BigItemsCount | Returns the number of objects to be displayed within the modules big preview.
Public Property | BigItemTemplate | Gets the item template for the big preview.
Public Property | CategoryParameter | Gets the categories parameter from context.items.
Public Property | CustomSetting | Returns a collection of the module custom settings.
Public Property | DetailPrintTemplate | Gets the print template.
Public Property | DetailViewTemplate | Gets the detail view template.
Public Property | FooterTemplate | Gets the footer template.
Public Property | HeaderTemplate | Gets the header template.
Public Property | IsDetailViewTableMustBeCached |
Public Property | IsInFirstItemViewMode | Gets a value indicating if the module is in feature mode.
Public Property | IsInRotationMode | Gets a value indicating if the module is in rotation mode.
Public Property | IsInTeaserMode | Gets a value indicating if the module is in teaser mode.
Public Property | objectcount | Returns the number of objects that should be shown inside the module.
Public Property | PagingSize | Returns the number of objects to be displayed on one page.
Public Property | RelatedAltItemTemplate | Gets the related object alternate item template (setting for related modules).
Public Property | RelatedItemsCount | Returns the number of related items.
Public Property | RelatedItemTemplate | Gets the related object item template (setting for related modules).
Public Property | RelationTypeFilter | Returns the selected relation type (setting for related modules).
Public Property | Settings | Overridden. Returns a hashtable containig the module settings.
Public Property | SmallColumnsCount | Returns the number of columns to display the modules small preview.
Public Property | SmallItemAltTemplate | Gets the alternate item template for the small preview.
Public Property | SmallItemsCount | Returns the number of objects to be displayed within the modules small preview.
Public Property | SmallItemTemplate | Gets the item template for the small preview.
Public Property | TypeFilter | Returns the selected object type (setting for related modules).
Public Property | UseCategoriesInUrlAND | Gets a value indicating to if related objects regarding multiple categories (AND/conjunction) passed in URL are to be shown (setting for related modules).
Public Property | UseCategoriesInUrlOR | Gets a value indicating if related objects regarding multiple categories (OR/disjunction) passed in URL are to be shown (setting for related modules).
Public Property | UseCategoryNavigation | Gets a value indicating if related objects regarding the category passed in URL are to be shown (setting for related modules).
Public Property | UseDefiniedCategories | Gets a value indicating if related objects regarding the specified categories are to be shown (setting for related modules).
Public Property | UseTypeFilter | Gets a value indicating if an object type filter is to be applied (setting for related modules).
Top

Protected Properties

 | Name | Description
Protected Property | DetailViewItemID | Returns the itemid of the current object in detail view.
Protected Property | IsInDetailView | Gets a value indicating if the module is in detail view of an object.
Protected Property | IsRelatedModule | Gets a value indicating if the module is a related module.
Protected Property | MoreLinkModuleID | Gets the teaser taget moduleid if the module is in teaser mode, otherwise it returns the current moduleid.
Protected Property | MoreLinkTabID | Gets the tabid for the teaser taget module if the module is in teaser mode, otherwise it returns the current tabid.
Protected Property | ObjectName | Gets the name of the object.
Protected Property | RequestedPage | Returns the number of the requested page when a paging command is present in the URL.
Top

See Also

Reference

ContentModuleDesktop Class
ContentXXL.Modules.Common Namespace


%%PageItemTitle%%

AutomaticallyRelatedMaxCount Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : AutomaticallyRelatedMaxCount Property

Returns the maximum amount of automatically related (category based) objects (setting for related modules).

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property AutomaticallyRelatedMaxCount As Integer
C#
public virtual int AutomaticallyRelatedMaxCount {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

BigColumnsCount Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : BigColumnsCount Property

Returns the number of columns to display the modules big preview.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property BigColumnsCount As Integer
C#
public virtual int BigColumnsCount {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

BigItemAltTemplate Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : BigItemAltTemplate Property

Gets the alternate item template for the big preview.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property BigItemAltTemplate As String
C#
public virtual string BigItemAltTemplate {get;}

Return Value

Path to the template (ascx file).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

BigItemsCount Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : BigItemsCount Property

Returns the number of objects to be displayed within the modules big preview.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property BigItemsCount As Integer
C#
public virtual int BigItemsCount {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

BigItemTemplate Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : BigItemTemplate Property

Gets the item template for the big preview.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property BigItemTemplate As String
C#
public virtual string BigItemTemplate {get;}

Return Value

Path to the template (ascx file).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

CategoryParameter Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : CategoryParameter Property

Gets the categories parameter from context.items.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property CategoryParameter As String
C#
public virtual string CategoryParameter {get;}

Return Value

Context.Items("categories")

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

CustomSetting Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : CustomSetting Property

Returns a collection of the module custom settings.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property CustomSetting As ModuleCustomSettingsCollection
C#
public virtual ModuleCustomSettingsCollection CustomSetting {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

DetailPrintTemplate Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : DetailPrintTemplate Property

Gets the print template.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property DetailPrintTemplate As String
C#
public virtual string DetailPrintTemplate {get;}

Return Value

Path to the template (ascx file).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

DetailViewItemID Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : DetailViewItemID Property

Returns the itemid of the current object in detail view.

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property DetailViewItemID As Integer
C#
protected int DetailViewItemID {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

DetailViewTemplate Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : DetailViewTemplate Property

Gets the detail view template.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property DetailViewTemplate As String
C#
public virtual string DetailViewTemplate {get;}

Return Value

Path to the template (ascx file).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

FooterTemplate Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : FooterTemplate Property

Gets the footer template.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property FooterTemplate As String
C#
public virtual string FooterTemplate {get;}

Return Value

Path to the template (ascx file).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

HeaderTemplate Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : HeaderTemplate Property

Gets the header template.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property HeaderTemplate As String
C#
public virtual string HeaderTemplate {get;}

Return Value

Path to the template (ascx file).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

IsDetailViewTableMustBeCached Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : IsDetailViewTableMustBeCached Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsDetailViewTableMustBeCached As Boolean
C#
public virtual bool IsDetailViewTableMustBeCached {get;}

Return Value

True

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

IsInDetailView Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : IsInDetailView Property

Gets a value indicating if the module is in detail view of an object.

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property IsInDetailView As Boolean
C#
protected virtual bool IsInDetailView {get;}

Return Value

True if the module is in detail view of an object, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

IsInFirstItemViewMode Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : IsInFirstItemViewMode Property

Gets a value indicating if the module is in feature mode.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsInFirstItemViewMode As Boolean
C#
public virtual bool IsInFirstItemViewMode {get;}

Return Value

True if the module is in feature mode, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

IsInRotationMode Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : IsInRotationMode Property

Gets a value indicating if the module is in rotation mode.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsInRotationMode As Boolean
C#
public virtual bool IsInRotationMode {get;}

Return Value

True if the module is in rotation mode, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

IsInTeaserMode Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : IsInTeaserMode Property

Gets a value indicating if the module is in teaser mode.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsInTeaserMode As Boolean
C#
public virtual bool IsInTeaserMode {get;}

Return Value

True if the module is in teaser mode, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

IsRelatedModule Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : IsRelatedModule Property

Gets a value indicating if the module is a related module.

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property IsRelatedModule As Boolean
C#
protected bool IsRelatedModule {get;}

Return Value

True if the module is a related module, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

MoreLinkModuleID Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : MoreLinkModuleID Property

Gets the teaser taget moduleid if the module is in teaser mode, otherwise it returns the current moduleid.

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property MoreLinkModuleID As Object
C#
protected virtual object MoreLinkModuleID {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

MoreLinkTabID Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : MoreLinkTabID Property

Gets the tabid for the teaser taget module if the module is in teaser mode, otherwise it returns the current tabid.

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property MoreLinkTabID As Integer
C#
protected virtual int MoreLinkTabID {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

objectcount Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : objectcount Property

Returns the number of objects that should be shown inside the module.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property objectcount As Integer
C#
public int objectcount {get;}

Return Value

Integer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

ObjectName Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : ObjectName Property

Gets the name of the object.

Syntax

Visual Basic (Declaration)
Protected MustOverride ReadOnly Property ObjectName As String
C#
protected abstract string ObjectName {get;}

Return Value

The name of the object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

PagingSize Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : PagingSize Property

Returns the number of objects to be displayed on one page.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property PagingSize As Integer
C#
public virtual int PagingSize {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

RelatedAltItemTemplate Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : RelatedAltItemTemplate Property

Gets the related object alternate item template (setting for related modules).

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property RelatedAltItemTemplate As String
C#
public virtual string RelatedAltItemTemplate {get;}

Return Value

Path to the template (ascx file).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

RelatedItemsCount Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : RelatedItemsCount Property

Returns the number of related items.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RelatedItemsCount As Integer
C#
public int RelatedItemsCount {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

RelatedItemTemplate Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : RelatedItemTemplate Property

Gets the related object item template (setting for related modules).

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property RelatedItemTemplate As String
C#
public virtual string RelatedItemTemplate {get;}

Return Value

Gets the related object alternate item template.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

RelationTypeFilter Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : RelationTypeFilter Property

Returns the selected relation type (setting for related modules).

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property RelationTypeFilter As String
C#
public virtual string RelationTypeFilter {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

RequestedPage Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : RequestedPage Property

Returns the number of the requested page when a paging command is present in the URL.

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property RequestedPage As Integer
C#
protected int RequestedPage {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

Settings Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : Settings Property

Returns a hashtable containig the module settings.

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property Settings As Hashtable
C#
public override Hashtable Settings {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

SmallColumnsCount Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : SmallColumnsCount Property

Returns the number of columns to display the modules small preview.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property SmallColumnsCount As Integer
C#
public virtual int SmallColumnsCount {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

SmallItemAltTemplate Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : SmallItemAltTemplate Property

Gets the alternate item template for the small preview.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property SmallItemAltTemplate As String
C#
public virtual string SmallItemAltTemplate {get;}

Return Value

Gets the item template for the small preview.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

SmallItemsCount Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : SmallItemsCount Property

Returns the number of objects to be displayed within the modules small preview.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property SmallItemsCount As Integer
C#
public virtual int SmallItemsCount {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

SmallItemTemplate Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : SmallItemTemplate Property

Gets the item template for the small preview.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property SmallItemTemplate As String
C#
public virtual string SmallItemTemplate {get;}

Return Value

Path to the template (ascx file).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

TypeFilter Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : TypeFilter Property

Returns the selected object type (setting for related modules).

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property TypeFilter As String
C#
public virtual string TypeFilter {get;}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

UseCategoriesInUrlAND Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : UseCategoriesInUrlAND Property

Gets a value indicating to if related objects regarding multiple categories (AND/conjunction) passed in URL are to be shown (setting for related modules).

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property UseCategoriesInUrlAND As Boolean
C#
public virtual bool UseCategoriesInUrlAND {get;}

Return Value

True if related objects regarding multiple categories (AND/conjunction) passed in URL are to be shown, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

UseCategoriesInUrlOR Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : UseCategoriesInUrlOR Property

Gets a value indicating if related objects regarding multiple categories (OR/disjunction) passed in URL are to be shown (setting for related modules).

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property UseCategoriesInUrlOR As Boolean
C#
public virtual bool UseCategoriesInUrlOR {get;}

Return Value

True if related objects regarding multiple categories (OR/disjunction) passed in URL are to be shown, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

UseCategoryNavigation Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : UseCategoryNavigation Property

Gets a value indicating if related objects regarding the category passed in URL are to be shown (setting for related modules).

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property UseCategoryNavigation As Boolean
C#
public virtual bool UseCategoryNavigation {get;}

Return Value

True if related objects regarding the category passed in URL are to be shown, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

UseDefiniedCategories Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : UseDefiniedCategories Property

Gets a value indicating if related objects regarding the specified categories are to be shown (setting for related modules).

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property UseDefiniedCategories As Boolean
C#
public virtual bool UseDefiniedCategories {get;}

Return Value

True if related objects regarding the specified categories are to be shown, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

UseTypeFilter Property
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : UseTypeFilter Property

Gets a value indicating if an object type filter is to be applied (setting for related modules).

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property UseTypeFilter As Boolean
C#
public virtual bool UseTypeFilter {get;}

Return Value

True if an object type filter is to be applied, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%% $$Fields$$

ContentModuleDesktop Class Fields
[image]
ContentXXL.Modules.Common Namespace : ContentModuleDesktop Class

For a list of all members of this type, see ContentModuleDesktop members.

Public Fields

 | Name | Description
Public Field | cdvBigView |
Public Field | cdvFooter |
Public Field | cdvHeader |
Public Field | cdvSmallView |
Top

Protected Fields

 | Name | Description
Protected Field | CustomDataFilterCustomization |
Protected Field | DescriptionPages | Array containing paged object descriptions.
Top

See Also

Reference

ContentModuleDesktop Class
ContentXXL.Modules.Common Namespace


%%PageItemTitle%%

cdvBigView Field
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : cdvBigView Field

Syntax

Visual Basic (Declaration)
Public cdvBigView As ContainerDataView
C#
public ContainerDataView cdvBigView

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

cdvFooter Field
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : cdvFooter Field

Syntax

Visual Basic (Declaration)
Public cdvFooter As ContainerDataView
C#
public ContainerDataView cdvFooter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

cdvHeader Field
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : cdvHeader Field

Syntax

Visual Basic (Declaration)
Public cdvHeader As ContainerDataView
C#
public ContainerDataView cdvHeader

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

cdvSmallView Field
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : cdvSmallView Field

Syntax

Visual Basic (Declaration)
Public cdvSmallView As ContainerDataView
C#
public ContainerDataView cdvSmallView

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

CustomDataFilterCustomization Field
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : CustomDataFilterCustomization Field

Syntax

Visual Basic (Declaration)
Protected CustomDataFilterCustomization As CustomDataFilterCustomization
C#
protected CustomDataFilterCustomization CustomDataFilterCustomization

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

DescriptionPages Field
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : DescriptionPages Field

Array containing paged object descriptions.

Syntax

Visual Basic (Declaration)
Protected DescriptionPages As Object()
C#
protected object[] DescriptionPages

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%% $$Events$$

ContentModuleDesktop Class Events
[image]
ContentXXL.Modules.Common Namespace : ContentModuleDesktop Class

For a list of all members of this type, see ContentModuleDesktop members.

Public Events

 | Name | Description
Public Event | AfterCreateDetailView | Occurs after the detail view is created.
Public Event | AfterCreateListView | Occurs after the list view is created.
Public Event | AfterSetLinks | Occurs after links are set (e.g. morelink).
Public Event | BeforeContainerDataBind | Occurs before data are bound to container.
Public Event | BeforeCreateDetailView | Occurs before the detail view is created.
Public Event | BeforeCreateListView | Occurs before the list view is created.
Public Event | BeforeSetLinks | Occurs before links are set (e.g. morelink).
Public Event | SetLinkItem | Occurs after all links for one item are set.
Top

See Also

Reference

ContentModuleDesktop Class
ContentXXL.Modules.Common Namespace


%%PageItemTitle%%

AfterCreateDetailView Event
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : AfterCreateDetailView Event

Occurs after the detail view is created.

Syntax

Visual Basic (Declaration)
Public Event AfterCreateDetailView() As AfterCreateDetailViewEventHandler
C#
public event AfterCreateDetailViewEventHandler AfterCreateDetailView()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

AfterCreateListView Event
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : AfterCreateListView Event

Occurs after the list view is created.

Syntax

Visual Basic (Declaration)
Public Event AfterCreateListView() As AfterCreateListViewEventHandler
C#
public event AfterCreateListViewEventHandler AfterCreateListView()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

AfterSetLinks Event
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : AfterSetLinks Event

Occurs after links are set (e.g. morelink).

Syntax

Visual Basic (Declaration)
Public Event AfterSetLinks() As AfterSetLinksEventHandler
C#
public event AfterSetLinksEventHandler AfterSetLinks()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

BeforeContainerDataBind Event
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : BeforeContainerDataBind Event

Occurs before data are bound to container.

Syntax

Visual Basic (Declaration)
Public Event BeforeContainerDataBind() As BeforeContainerDataBindEventHandler
C#
public event BeforeContainerDataBindEventHandler BeforeContainerDataBind()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

BeforeCreateDetailView Event
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : BeforeCreateDetailView Event

Occurs before the detail view is created.

Syntax

Visual Basic (Declaration)
Public Event BeforeCreateDetailView() As BeforeCreateDetailViewEventHandler
C#
public event BeforeCreateDetailViewEventHandler BeforeCreateDetailView()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

BeforeCreateListView Event
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : BeforeCreateListView Event

Occurs before the list view is created.

Syntax

Visual Basic (Declaration)
Public Event BeforeCreateListView() As BeforeCreateListViewEventHandler
C#
public event BeforeCreateListViewEventHandler BeforeCreateListView()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

BeforeSetLinks Event
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : BeforeSetLinks Event

Occurs before links are set (e.g. morelink).

Syntax

Visual Basic (Declaration)
Public Event BeforeSetLinks() As BeforeSetLinksEventHandler
C#
public event BeforeSetLinksEventHandler BeforeSetLinks()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

SetLinkItem Event
[image]
ContentXXL.Modules.Common Namespace > ContentModuleDesktop Class : SetLinkItem Event

Occurs after all links for one item are set.

Syntax

Visual Basic (Declaration)
Public Event SetLinkItem() As SetLinkItemEventHandler
C#
public event SetLinkItemEventHandler SetLinkItem()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentModuleDesktop Class
ContentModuleDesktop Members

© contentXXL International. All Rights Reserved.


%%PageItemTitle%%

AfterCreateDetailViewEventHandler Delegate
[image]
ContentXXL.Modules.Common Namespace : AfterCreateDetailViewEventHandler Delegate

source
dt

Syntax

Visual Basic (Declaration)
Public Delegate Sub AfterCreateDetailViewEventHandler( _
   ByVal source As Object, _
   ByRef dt As DataTable _
)
C#
public delegate void AfterCreateDetailViewEventHandler(
   object source,
   ref DataTable dt
)

Parameters

source
dt

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentXXL.Modules.Common Namespace


%%PageItemTitle%%

AfterCreateListViewEventHandler Delegate
[image]
ContentXXL.Modules.Common Namespace : AfterCreateListViewEventHandler Delegate

source
dt

Syntax

Visual Basic (Declaration)
Public Delegate Sub AfterCreateListViewEventHandler( _
   ByVal source As Object, _
   ByRef dt As DataTable _
)
C#
public delegate void AfterCreateListViewEventHandler(
   object source,
   ref DataTable dt
)

Parameters

source
dt

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentXXL.Modules.Common Namespace


%%PageItemTitle%%

AfterSetLinksEventHandler Delegate
[image]
ContentXXL.Modules.Common Namespace : AfterSetLinksEventHandler Delegate

source
dt

Syntax

Visual Basic (Declaration)
Public Delegate Sub AfterSetLinksEventHandler( _
   ByVal source As Object, _
   ByRef dt As DataTable _
)
C#
public delegate void AfterSetLinksEventHandler(
   object source,
   ref DataTable dt
)

Parameters

source
dt

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentXXL.Modules.Common Namespace


%%PageItemTitle%%

BeforeContainerDataBindEventHandler Delegate
[image]
ContentXXL.Modules.Common Namespace : BeforeContainerDataBindEventHandler Delegate

source
e

Syntax

Visual Basic (Declaration)
Public Delegate Sub BeforeContainerDataBindEventHandler( _
   ByVal source As ContainerDataView, _
   ByVal e As EventArgs _
)
C#
public delegate void BeforeContainerDataBindEventHandler(
   ContainerDataView source,
   EventArgs e
)

Parameters

source
e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentXXL.Modules.Common Namespace


%%PageItemTitle%%

BeforeCreateDetailViewEventHandler Delegate
[image]
ContentXXL.Modules.Common Namespace : BeforeCreateDetailViewEventHandler Delegate

source
dt

Syntax

Visual Basic (Declaration)
Public Delegate Sub BeforeCreateDetailViewEventHandler( _
   ByVal source As Object, _
   ByRef dt As DataTable _
)
C#
public delegate void BeforeCreateDetailViewEventHandler(
   object source,
   ref DataTable dt
)

Parameters

source
dt

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentXXL.Modules.Common Namespace


%%PageItemTitle%%

BeforeCreateListViewEventHandler Delegate
[image]
ContentXXL.Modules.Common Namespace : BeforeCreateListViewEventHandler Delegate

source
dt

Syntax

Visual Basic (Declaration)
Public Delegate Sub BeforeCreateListViewEventHandler( _
   ByVal source As Object, _
   ByRef dt As DataTable _
)
C#
public delegate void BeforeCreateListViewEventHandler(
   object source,
   ref DataTable dt
)

Parameters

source
dt

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentXXL.Modules.Common Namespace


%%PageItemTitle%%

BeforeSetLinksEventHandler Delegate
[image]
ContentXXL.Modules.Common Namespace : BeforeSetLinksEventHandler Delegate

source
dt

Syntax

Visual Basic (Declaration)
Public Delegate Sub BeforeSetLinksEventHandler( _
   ByVal source As Object, _
   ByRef dt As DataTable _
)
C#
public delegate void BeforeSetLinksEventHandler(
   object source,
   ref DataTable dt
)

Parameters

source
dt

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentXXL.Modules.Common Namespace


%%PageItemTitle%%

SetLinkItemEventHandler Delegate
[image]
ContentXXL.Modules.Common Namespace : SetLinkItemEventHandler Delegate

source
dr

Syntax

Visual Basic (Declaration)
Public Delegate Sub SetLinkItemEventHandler( _
   ByVal source As Object, _
   ByRef dr As DataRow _
)
C#
public delegate void SetLinkItemEventHandler(
   object source,
   ref DataRow dr
)

Parameters

source
dr

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentXXL.Modules.Common Namespace


%%phrase%%

contentXXL Assembly

Namespaces

Namespace | Description
ContentXXL.Modules.Common |


$$GETTING_STARTED$$ - %%projecttitle%%

Getting Started


$$INTRODUCTION$$ - %%projecttitle%%

Introduction


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ContentXXL.Modules.Common Namespace Inheritance Hierarchy

See Also

Reference

contentXXL Assembly