%%ItemTitle%%

contentXXL Send comments on this topic.
ContentXXL.Content Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
ContentObjectBase | This class is a base class for any contentXXL object and provides varíous methods to handle this objects.
ContentObjectBaseExtended | This class is inherited from the ContentObjectBase class and provides a set of properties to access additional database fields.

See Also

Reference

contentXXL Assembly

© contentXXL International. All Rights Reserved.


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

ContentXXL.Content Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

ContentXXL.Content.ContentObjectBase
ContentXXL.Content.ContentObjectBaseExtended

See Also

Reference

contentXXL Assembly


%%PageItemTitle%%

ContentObjectBase Class
See Also Members
[image]
ContentXXL.Content Namespace : ContentObjectBase Class

This class is a base class for any contentXXL object and provides varíous methods to handle this objects.

Syntax

Visual Basic (Declaration)
Public MustInherit Class ContentObjectBase
   Inherits GenericVersionObject
C#
public abstract class ContentObjectBase : GenericVersionObject

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Members
ContentXXL.Content Namespace


%%PageItemTitle%% $$Members$$

ContentObjectBase Class Members
See Also Properties Methods
[image]
ContentXXL.Content Namespace : ContentObjectBase Class

The following tables list the members exposed by ContentObjectBase.

Public Constructors

 | Name | Description
Public Constructor | ContentObjectBase Constructor | Overloaded. Initializes a new instance of the ContentObjectBase class.
Top

Public Properties

 | Name | Description
Public Property | FilterStandardLanguage | Gets or sets a value indicating whether 'Enable Language filter' (module setting) is active.
Public Property | IsBufferValid | Gets a value indicating whether this instance can fetched from buffer (paste operation).
Public Property | IsInPresentationLayer | Gets or sets a value indicating whether this instance is in presentation layer.
Top

Public Methods

 | Name | Description
Public Method | CanCreate | Determines whether the current user has create rights the specified module.
Public Method | Copy | Copies this instance to a session variable.
static (Shared in Visual Basic) | CreateInstance | Overloaded. Creates an instance of an object.
static (Shared in Visual Basic) | CreateInstanceByModuleDefID | Creates an instance of a new object (an object which not yet exists in the database) in the context of the specified ModuleDefID.
Public Method | GetAllLanguageVersionsByModuleID | Overloaded.
Public Method | GetAllPublishedObjects | Gets all objects published in the specified module.
Public Method | GetAssigmentsForResource | Gets all objects assigned to the specified resource in the ResourceAssign table.
Public Method | getauthor | Gets the author of this instance.
Public Method | GetByCategoryID | Gets all objects assigned to the specified categoryID with option to filter for objecttype.
Public Method | GetByCategoryRelated | Overloaded.
Public Method | GetByModuleID | Overloaded. Gets all objects belonging to the specified module and published.
Public Method | GetByModuleIDForTeaserView | Gets all objects available for teaser few mode in the specified module (published in a second module).
Public Method | GetByModuleIDXml | Gets all objects belonging to the specified module and published.
Public Method | GetByUrlCategoryIDsAND | Gets all objects assigned to the all categoryIDs in the specified list of categories with option to filter for objecttype.
Public Method | GetByUrlCategoryIDsOR | Gets all objects assigned to the one categoryID in the specified list of categories with option to filter for objecttype.
Public Method | getkeywords | Gets the keywords of this instance.
Public Method | GetManuallyRelated | Overloaded. Gets all objects which are manually related to the specified object.
Public Method | GetManuallyRelatedForWholeModule | Gets all objects which are manually related to the specified module with option to filter for the specified object type and relation type.
Public Method | GetModuleDefID | Gets the ModuleDefinitionID.
Public Method | GetNotPublished | Gets the objects which are not published.
Public Method | GetObjectEditManagerLink | Overloaded. Gets the link to the Object Edit Manager for the current object instance.
Public Method | getpreview | Gets the preview of this instance.
Public Method | GetSingleViewTable | Gets the single view datatable.
Public Method | GetSingleViewTableForPreview | Gets the single view datatable for preview.
Public Method | gettitle | Gets the title of this instance.
static (Shared in Visual Basic) | GetTopicMapDataSet | Overloaded. Gets the topic map data set.
Public Method | Paste | Overloaded. Pastes this instance from a session variable.
Public Method | PublishWithPublishRule | Publishes the current instance applying the publishrule of the specified module.
Public Method | Save | Overloaded. Sets the module context to lModuleID and calls the save method of the base class.
Public Method | Search | Overloaded.
Public Method | ToXml | Overloaded.
Top

See Also

Reference

ContentObjectBase Class
ContentXXL.Content Namespace


%%PageItemTitle%%

ContentObjectBase Constructor
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : ContentObjectBase Constructor

Initializes a new instance of the ContentObjectBase class.

Overload List

Overload | Description
ContentObjectBase Constructor() | Initializes a new instance of the ContentObjectBase class and sets PortalId and LanguageID to the current values.
ContentObjectBase Constructor(Int32,Int32) | Initializes a new instance of the ContentObjectBase class.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

ContentObjectBase Constructor()
See Also
[image]
ContentXXL.Content Namespace > ContentObjectBase Class > ContentObjectBase Constructor : ContentObjectBase Constructor()

Initializes a new instance of the ContentObjectBase class and sets PortalId and LanguageID to the current values.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public ContentObjectBase()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members
Overload List


%%PageItemTitle%%

ContentObjectBase Constructor(Int32,Int32)
See Also
[image]
ContentXXL.Content Namespace > ContentObjectBase Class > ContentObjectBase Constructor : ContentObjectBase Constructor(Int32,Int32)

lPortalID
The PortalID.
lLanguageID
The LanguageID.
Initializes a new instance of the ContentObjectBase class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal lPortalID As Integer, _
   ByVal lLanguageID As Integer _
)
C#
public ContentObjectBase(
   int lPortalID,
   int lLanguageID
)

Parameters

lPortalID
The PortalID.
lLanguageID
The LanguageID.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members
Overload List


%%PageItemTitle%% $$Methods$$

ContentObjectBase Class Methods
[image]
ContentXXL.Content Namespace : ContentObjectBase Class

For a list of all members of this type, see ContentObjectBase members.

Public Methods

 | Name | Description
Public Method | CanCreate | Determines whether the current user has create rights the specified module.
Public Method | Copy | Copies this instance to a session variable.
static (Shared in Visual Basic) | CreateInstance | Overloaded. Creates an instance of an object.
static (Shared in Visual Basic) | CreateInstanceByModuleDefID | Creates an instance of a new object (an object which not yet exists in the database) in the context of the specified ModuleDefID.
Public Method | GetAllLanguageVersionsByModuleID | Overloaded.
Public Method | GetAllPublishedObjects | Gets all objects published in the specified module.
Public Method | GetAssigmentsForResource | Gets all objects assigned to the specified resource in the ResourceAssign table.
Public Method | getauthor | Gets the author of this instance.
Public Method | GetByCategoryID | Gets all objects assigned to the specified categoryID with option to filter for objecttype.
Public Method | GetByCategoryRelated | Overloaded.
Public Method | GetByModuleID | Overloaded. Gets all objects belonging to the specified module and published.
Public Method | GetByModuleIDForTeaserView | Gets all objects available for teaser few mode in the specified module (published in a second module).
Public Method | GetByModuleIDXml | Gets all objects belonging to the specified module and published.
Public Method | GetByUrlCategoryIDsAND | Gets all objects assigned to the all categoryIDs in the specified list of categories with option to filter for objecttype.
Public Method | GetByUrlCategoryIDsOR | Gets all objects assigned to the one categoryID in the specified list of categories with option to filter for objecttype.
Public Method | getkeywords | Gets the keywords of this instance.
Public Method | GetManuallyRelated | Overloaded. Gets all objects which are manually related to the specified object.
Public Method | GetManuallyRelatedForWholeModule | Gets all objects which are manually related to the specified module with option to filter for the specified object type and relation type.
Public Method | GetModuleDefID | Gets the ModuleDefinitionID.
Public Method | GetNotPublished | Gets the objects which are not published.
Public Method | GetObjectEditManagerLink | Overloaded. Gets the link to the Object Edit Manager for the current object instance.
Public Method | getpreview | Gets the preview of this instance.
Public Method | GetSingleViewTable | Gets the single view datatable.
Public Method | GetSingleViewTableForPreview | Gets the single view datatable for preview.
Public Method | gettitle | Gets the title of this instance.
static (Shared in Visual Basic) | GetTopicMapDataSet | Overloaded. Gets the topic map data set.
Public Method | Paste | Overloaded. Pastes this instance from a session variable.
Public Method | PublishWithPublishRule | Publishes the current instance applying the publishrule of the specified module.
Public Method | Save | Overloaded. Sets the module context to lModuleID and calls the save method of the base class.
Public Method | Search | Overloaded.
Public Method | ToXml | Overloaded.
Top

See Also

Reference

ContentObjectBase Class
ContentXXL.Content Namespace


%%PageItemTitle%%

CanCreate Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : CanCreate Method

moduleID
The moduleID.
Determines whether the current user has create rights the specified module.

Syntax

Visual Basic (Declaration)
Public Overridable Function CanCreate( _
   ByVal moduleID As Integer _
) As Boolean
C#
public virtual bool CanCreate(
   int moduleID
)

Parameters

moduleID
The moduleID.

Return Value

true if the current user has the right to create a new object the specified module; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

Copy Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : Copy Method

Copies this instance to a session variable.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Copy()
C#
public virtual void Copy()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

CreateInstance Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : CreateInstance Method

Creates an instance of an object.

Overload List

Overload | Description
CreateInstance(String,Int32,Int32,Boolean) | Creates an instance of an object.
CreateInstance(String,Int32,Int32) | Creates an instance of an object.
CreateInstance(Int32) | Creates an instance of a new object (an object which not yet exists in the database) in the context of the specified module.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

CreateInstance(String,Int32,Int32,Boolean) Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class > CreateInstance Method : CreateInstance(String,Int32,Int32,Boolean) Method

lGlobalID
The GlobalID of the specified object.
lLanguageID
The language to be loaded.
lVersion
The version to be loaded.
lLoadData
If set to false, GlobalID, language and version are ignored and an emtpy object is created.
Creates an instance of an object.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function CreateInstance( _
   ByVal lGlobalID As String, _
   ByVal lLanguageID As Integer, _
   ByVal lVersion As Integer, _
   ByVal lLoadData As Boolean _
) As ContentObjectBase
C#
public static ContentObjectBase CreateInstance(
   string lGlobalID,
   int lLanguageID,
   int lVersion,
   bool lLoadData
)

Parameters

lGlobalID
The GlobalID of the specified object.
lLanguageID
The language to be loaded.
lVersion
The version to be loaded.
lLoadData
If set to false, GlobalID, language and version are ignored and an emtpy object is created.

Return Value

The object instance.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members
Overload List


%%PageItemTitle%%

CreateInstance(String,Int32,Int32) Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class > CreateInstance Method : CreateInstance(String,Int32,Int32) Method

lGlobalID
The GlobalID of the specified object.
lLanguageID
The language to be loaded.
lVersion
The version to be loaded.
Creates an instance of an object.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function CreateInstance( _
   ByVal lGlobalID As String, _
   ByVal lLanguageID As Integer, _
   ByVal lVersion As Integer _
) As ContentObjectBase
C#
public static ContentObjectBase CreateInstance(
   string lGlobalID,
   int lLanguageID,
   int lVersion
)

Parameters

lGlobalID
The GlobalID of the specified object.
lLanguageID
The language to be loaded.
lVersion
The version to be loaded.

Return Value

The object instance.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members
Overload List


%%PageItemTitle%%

CreateInstance(Int32) Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class > CreateInstance Method : CreateInstance(Int32) Method

lModuleID
The ModuleID.
Creates an instance of a new object (an object which not yet exists in the database) in the context of the specified module.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function CreateInstance( _
   ByVal lModuleID As Integer _
) As ContentObjectBase
C#
public static ContentObjectBase CreateInstance(
   int lModuleID
)

Parameters

lModuleID
The ModuleID.

Return Value

The object instance.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members
Overload List


%%PageItemTitle%%

CreateInstanceByModuleDefID Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : CreateInstanceByModuleDefID Method

lModuleDefID
The ModuleDefID.
Creates an instance of a new object (an object which not yet exists in the database) in the context of the specified ModuleDefID.

Syntax

Visual Basic (Declaration)
Public Shared Function CreateInstanceByModuleDefID( _
   ByVal lModuleDefID As Integer _
) As ContentObjectBase
C#
public static ContentObjectBase CreateInstanceByModuleDefID(
   int lModuleDefID
)

Parameters

lModuleDefID
The ModuleDefID.

Return Value

Te object instance.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

GetAllLanguageVersionsByModuleID Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : GetAllLanguageVersionsByModuleID Method

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

GetAllPublishedObjects Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : GetAllPublishedObjects Method

lModuleID
The ModuleID.
Gets all objects published in the specified module.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetAllPublishedObjects( _
   ByVal lModuleID As Integer _
) As DataTable
C#
public virtual DataTable GetAllPublishedObjects(
   int lModuleID
)

Parameters

lModuleID
The ModuleID.

Return Value

Datatable containing the objects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

GetAssigmentsForResource Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : GetAssigmentsForResource Method

resourceID
Datatable containg the assigned objects.
Gets all objects assigned to the specified resource in the ResourceAssign table.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetAssigmentsForResource( _
   ByVal resourceID As Integer _
) As DataTable
C#
public virtual DataTable GetAssigmentsForResource(
   int resourceID
)

Parameters

resourceID
Datatable containg the assigned objects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

getauthor Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : getauthor Method

Gets the author of this instance.

Syntax

Visual Basic (Declaration)
Public Overridable Function getauthor() As String
C#
public virtual string getauthor()

Return Value

Empty string.

Remarks

implemented in the inheriting object classes to return the author of the object instance.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

GetByCategoryID Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : GetByCategoryID Method

categoryID
The categoryID.
objectType
Type of the object. Set to -1 for 'do not filter'.
Gets all objects assigned to the specified categoryID with option to filter for objecttype.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetByCategoryID( _
   ByVal categoryID As Integer, _
   ByVal objectType As String _
) As Object
C#
public virtual object GetByCategoryID(
   int categoryID,
   string objectType
)

Parameters

categoryID
The categoryID.
objectType
Type of the object. Set to -1 for 'do not filter'.

Return Value

Dataset containing the objects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

GetByCategoryRelated Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : GetByCategoryRelated Method

Overload List

Overload | Description
GetByCategoryRelated(String,Boolean,String) | Gets all objects which are related by category to the specified object with option to filter for objecttype.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

GetByCategoryRelated(String,Boolean,String) Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class > GetByCategoryRelated Method : GetByCategoryRelated(String,Boolean,String) Method

lGlobalID
The object GlobalID.
PublishedONly
If set to true, filter for objectType is applied.
objectType
Type of the object. Set to -1 for 'do not filter'.
Gets all objects which are related by category to the specified object with option to filter for objecttype.

Syntax

Visual Basic (Declaration)
Overloads Public Overridable Function GetByCategoryRelated( _
   ByVal lGlobalID As String, _
   ByVal PublishedONly As Boolean, _
   ByVal objectType As String _
) As DataSet
C#
public virtual DataSet GetByCategoryRelated(
   string lGlobalID,
   bool PublishedONly,
   string objectType
)

Parameters

lGlobalID
The object GlobalID.
PublishedONly
If set to true, filter for objectType is applied.
objectType
Type of the object. Set to -1 for 'do not filter'.

Return Value

Dataset containing the related objects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members
Overload List


%%PageItemTitle%%

GetByModuleID Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : GetByModuleID Method

Gets all objects belonging to the specified module and published.

Overload List

Overload | Description
GetByModuleID(Int32) | Gets all objects belonging to the specified module and published.
GetByModuleID(Int32,Boolean) | Gets all objects belonging to the specified module with option to filter for published objects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

GetByModuleID(Int32) Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class > GetByModuleID Method : GetByModuleID(Int32) Method

lModuleID
The ModuleID.
Gets all objects belonging to the specified module and published.

Syntax

Visual Basic (Declaration)
Overloads Public Overridable Function GetByModuleID( _
   ByVal lModuleID As Integer _
) As DataSet
C#
public virtual DataSet GetByModuleID(
   int lModuleID
)

Parameters

lModuleID
The ModuleID.

Return Value

Dataset containing the objects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members
Overload List


%%PageItemTitle%%

GetByModuleID(Int32,Boolean) Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class > GetByModuleID Method : GetByModuleID(Int32,Boolean) Method

lModuleID
The ModuleID.
PublishedOnly
if set to true, only published objects are retrieved.
Gets all objects belonging to the specified module with option to filter for published objects.

Syntax

Visual Basic (Declaration)
Overloads Public Overridable Function GetByModuleID( _
   ByVal lModuleID As Integer, _
   ByVal PublishedOnly As Boolean _
) As DataSet
C#
public virtual DataSet GetByModuleID(
   int lModuleID,
   bool PublishedOnly
)

Parameters

lModuleID
The ModuleID.
PublishedOnly
if set to true, only published objects are retrieved.

Return Value

Dataset containing the objects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members
Overload List


%%PageItemTitle%%

GetByModuleIDForTeaserView Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : GetByModuleIDForTeaserView Method

lModuleID
The ModuleID.
Gets all objects available for teaser few mode in the specified module (published in a second module).

Syntax

Visual Basic (Declaration)
Public Overridable Function GetByModuleIDForTeaserView( _
   ByVal lModuleID As Integer _
) As DataSet
C#
public virtual DataSet GetByModuleIDForTeaserView(
   int lModuleID
)

Parameters

lModuleID
The ModuleID.

Return Value

Dataset containing the objects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

GetByModuleIDXml Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : GetByModuleIDXml Method

lModuleID
The ModuleID.
Gets all objects belonging to the specified module and published.

Syntax

Visual Basic (Declaration)
Public Function GetByModuleIDXml( _
   ByVal lModuleID As Integer _
) As XmlDocument
C#
public XmlDocument GetByModuleIDXml(
   int lModuleID
)

Parameters

lModuleID
The ModuleID.

Return Value

XMLDocument containing the objects.

Remarks

Corresponds to the GetByModuleID method, which returns a dataset.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

GetByUrlCategoryIDsAND Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : GetByUrlCategoryIDsAND Method

categoryIDs
The comma separated list of categoryIDs
objectType
Type of the object. Set to -1 for 'do not filter'.
Gets all objects assigned to the all categoryIDs in the specified list of categories with option to filter for objecttype.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetByUrlCategoryIDsAND( _
   ByVal categoryIDs As String, _
   ByVal objectType As String _
) As DataSet
C#
public virtual DataSet GetByUrlCategoryIDsAND(
   string categoryIDs,
   string objectType
)

Parameters

categoryIDs
The comma separated list of categoryIDs
objectType
Type of the object. Set to -1 for 'do not filter'.

Return Value

Dataset containing the objects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

GetByUrlCategoryIDsOR Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : GetByUrlCategoryIDsOR Method

categoryIDs
The comma separated list of categoryIDs
objectType
Type of the object. Set to -1 for 'do not filter'.
Gets all objects assigned to the one categoryID in the specified list of categories with option to filter for objecttype.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetByUrlCategoryIDsOR( _
   ByVal categoryIDs As String, _
   ByVal objectType As String _
) As DataSet
C#
public virtual DataSet GetByUrlCategoryIDsOR(
   string categoryIDs,
   string objectType
)

Parameters

categoryIDs
The comma separated list of categoryIDs
objectType
Type of the object. Set to -1 for 'do not filter'.

Return Value

Dataset containing the objects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

getkeywords Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : getkeywords Method

Gets the keywords of this instance.

Syntax

Visual Basic (Declaration)
Public Overridable Function getkeywords() As String
C#
public virtual string getkeywords()

Return Value

Empty string.

Remarks

implemented in the inheriting object classes to return the keywords of the object instance.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

GetManuallyRelated Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : GetManuallyRelated Method

Gets all objects which are manually related to the specified object.

Overload List

Overload | Description
GetManuallyRelated(String) | Gets all objects which are manually related to the specified object.
GetManuallyRelated(String,Boolean,String,String) | Gets all objects which are manually related to the specified object with option to filter for the specified object type and relation type.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

GetManuallyRelated(String) Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class > GetManuallyRelated Method : GetManuallyRelated(String) Method

lGlobalID
The object GlobalID.
Gets all objects which are manually related to the specified object.

Syntax

Visual Basic (Declaration)
Overloads Public Function GetManuallyRelated( _
   ByVal lGlobalID As String _
) As DataSet
C#
public DataSet GetManuallyRelated(
   string lGlobalID
)

Parameters

lGlobalID
The object GlobalID.

Return Value

Dataset containing the related objects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members
Overload List


%%PageItemTitle%%

GetManuallyRelated(String,Boolean,String,String) Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class > GetManuallyRelated Method : GetManuallyRelated(String,Boolean,String,String) Method

lGlobalID
The object GlobalID.
PublishedOnly
if set to true, filter for objectType and relationType is applied.
objectType
Type of the object. May be -1 for 'do no filter', 0 or String.Empty for 'only objects without type', ObjectTypeKey from table ContentObjectType for 'only given type'.
relationType
Type of the relation. May be -1 for 'do no filter', 0 or String.Empty for 'only relations without type', ObjectTypeKey from table ContentObjectType for 'only given type'.
Gets all objects which are manually related to the specified object with option to filter for the specified object type and relation type.

Syntax

Visual Basic (Declaration)
Overloads Public Overridable Function GetManuallyRelated( _
   ByVal lGlobalID As String, _
   ByVal PublishedOnly As Boolean, _
   ByVal objectType As String, _
   ByVal relationType As String _
) As DataSet
C#
public virtual DataSet GetManuallyRelated(
   string lGlobalID,
   bool PublishedOnly,
   string objectType,
   string relationType
)

Parameters

lGlobalID
The object GlobalID.
PublishedOnly
if set to true, filter for objectType and relationType is applied.
objectType
Type of the object. May be -1 for 'do no filter', 0 or String.Empty for 'only objects without type', ObjectTypeKey from table ContentObjectType for 'only given type'.
relationType
Type of the relation. May be -1 for 'do no filter', 0 or String.Empty for 'only relations without type', ObjectTypeKey from table ContentObjectType for 'only given type'.

Return Value

Dataset containing the related objects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members
Overload List


%%PageItemTitle%%

GetManuallyRelatedForWholeModule Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : GetManuallyRelatedForWholeModule Method

moduleid
The moduleid.
objecttype
The objecttype. May be -1 for 'do no filter', 0 or String.Empty for 'only objects without type', ObjectTypeKey from table ContentObjectType for 'only given type'.
relationtype
The relationtype. May be -1 for 'do no filter', 0 or String.Empty for 'only relations without type', ObjectTypeKey from table ContentObjectType for 'only given type'.

Gets all objects which are manually related to the specified module with option to filter for the specified object type and relation type.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetManuallyRelatedForWholeModule( _
   ByVal moduleid As Integer, _
   ByVal objecttype As String, _
   ByVal relationtype As String _
) As DataSet
C#
public virtual DataSet GetManuallyRelatedForWholeModule(
   int moduleid,
   string objecttype,
   string relationtype
)

Parameters

moduleid
The moduleid.
objecttype
The objecttype. May be -1 for 'do no filter', 0 or String.Empty for 'only objects without type', ObjectTypeKey from table ContentObjectType for 'only given type'.
relationtype
The relationtype. May be -1 for 'do no filter', 0 or String.Empty for 'only relations without type', ObjectTypeKey from table ContentObjectType for 'only given type'.

Return Value

Dataset containing the related objects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

GetModuleDefID Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : GetModuleDefID Method

Gets the ModuleDefinitionID.

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetModuleDefID() As Integer
C#
public abstract int GetModuleDefID()

Return Value

the ModuleDefinitionID from table ModuleDefinitions

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

GetNotPublished Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : GetNotPublished Method

Gets the objects which are not published.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetNotPublished() As DataSet
C#
public virtual DataSet GetNotPublished()

Return Value

Dataset containing all objects which are not published.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

GetObjectEditManagerLink Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : GetObjectEditManagerLink Method

Gets the link to the Object Edit Manager for the current object instance.

Overload List

Overload | Description
GetObjectEditManagerLink(Int32) | Gets the link to the Object Edit Manager for the current object instance.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

GetObjectEditManagerLink(Int32) Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class > GetObjectEditManagerLink Method : GetObjectEditManagerLink(Int32) Method

lModuleID
The ModuleID.
Gets the link to the Object Edit Manager for the current object instance.

Syntax

Visual Basic (Declaration)
Overloads Public Overridable Function GetObjectEditManagerLink( _
   ByVal lModuleID As Integer _
) As String
C#
public virtual string GetObjectEditManagerLink(
   int lModuleID
)

Parameters

lModuleID
The ModuleID.

Return Value

Link to edit the current object in the Object Edit Manager.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members
Overload List


%%PageItemTitle%%

getpreview Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : getpreview Method

Gets the preview of this instance.

Syntax

Visual Basic (Declaration)
Public Overridable Function getpreview() As String
C#
public virtual string getpreview()

Return Value

Empty string.

Remarks

implemented in the inheriting object classes to return the preview of the object instance.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

GetSingleViewTable Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : GetSingleViewTable Method

Itemid
The object itemid.
moduleid
The moduleid.
Gets the single view datatable.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetSingleViewTable( _
   ByVal Itemid As Integer, _
   ByVal moduleid As Integer _
) As DataTable
C#
public virtual DataTable GetSingleViewTable(
   int Itemid,
   int moduleid
)

Parameters

Itemid
The object itemid.
moduleid
The moduleid.

Return Value

Datatable containing all object data to display a single view in the specified module.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

GetSingleViewTableForPreview Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : GetSingleViewTableForPreview Method

Itemid
The object itemid.
moduleid
The moduleid.
Gets the single view datatable for preview.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetSingleViewTableForPreview( _
   ByVal Itemid As Integer, _
   ByVal moduleid As Integer _
) As DataTable
C#
public virtual DataTable GetSingleViewTableForPreview(
   int Itemid,
   int moduleid
)

Parameters

Itemid
The object itemid.
moduleid
The moduleid.

Return Value

Datatable containing all object data to display a single view preview in the specified module.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

gettitle Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : gettitle Method

Gets the title of this instance.

Syntax

Visual Basic (Declaration)
Public Overridable Function gettitle() As String
C#
public virtual string gettitle()

Return Value

empty string

Remarks

implemented in the inheriting object classes to return the title of the object instance.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

GetTopicMapDataSet Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : GetTopicMapDataSet Method

Gets the topic map data set.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

Paste Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : Paste Method

Pastes this instance from a session variable.

Overload List

Overload | Description
Paste() | Pastes this instance from a session variable.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

Paste() Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class > Paste Method : Paste() Method

Pastes this instance from a session variable.

Syntax

Visual Basic (Declaration)
Overloads Public Overridable Sub Paste()
C#
public virtual void Paste()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members
Overload List


%%PageItemTitle%%

PublishWithPublishRule Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : PublishWithPublishRule Method

moduleID
The ModuleID.
Publishes the current instance applying the publishrule of the specified module.

Syntax

Visual Basic (Declaration)
Public Sub PublishWithPublishRule( _
   ByVal moduleID As Integer _
)
C#
public void PublishWithPublishRule(
   int moduleID
)

Parameters

moduleID
The ModuleID.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

Save Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : Save Method

Sets the module context to lModuleID and calls the save method of the base class.

Overload List

Overload | Description
Save(Int32) | Sets the module context to lModuleID and calls the save method of the base class.
Save(Int32,Boolean) | Sets the module context to lModuleID and calls the save method of the base class and provides the option to apply the publishrole of the specified module.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

Save(Int32) Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class > Save Method : Save(Int32) Method

lModuleID
The ModuleID.
Sets the module context to lModuleID and calls the save method of the base class.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal lModuleID As Integer _
)
C#
public void Save(
   int lModuleID
)

Parameters

lModuleID
The ModuleID.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members
Overload List


%%PageItemTitle%%

Save(Int32,Boolean) Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class > Save Method : Save(Int32,Boolean) Method

moduleID
The ModuleID.
publish
if set to true, the publishrule assigned to the specified moduleID is applied

Sets the module context to lModuleID and calls the save method of the base class and provides the option to apply the publishrole of the specified module.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal moduleID As Integer, _
   ByVal publish As Boolean _
)
C#
public void Save(
   int moduleID,
   bool publish
)

Parameters

moduleID
The ModuleID.
publish
if set to true, the publishrule assigned to the specified moduleID is applied

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members
Overload List


%%PageItemTitle%%

Search Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : Search Method

Overload List

Overload | Description
Search(String,Boolean) | Searches any field in the underlying object table for the specified query string with option to filter for published objects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

Search(String,Boolean) Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class > Search Method : Search(String,Boolean) Method

Query
The string to be searched for.
PublishedOnly
if set to true only published objects are retrieved.
Searches any field in the underlying object table for the specified query string with option to filter for published objects.

Syntax

Visual Basic (Declaration)
Overloads Public Overridable Function Search( _
   ByVal Query As String, _
   ByVal PublishedOnly As Boolean _
) As DataSet
C#
public virtual DataSet Search(
   string Query,
   bool PublishedOnly
)

Parameters

Query
The string to be searched for.
PublishedOnly
if set to true only published objects are retrieved.

Return Value

Dataset containing the objects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members
Overload List


%%PageItemTitle%%

ToXml Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : ToXml Method

Overload List

Overload | Description
ToXml() |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

ToXml() Method
[image]
ContentXXL.Content Namespace > ContentObjectBase Class > ToXml Method : ToXml() Method

Syntax

Visual Basic (Declaration)
Overloads Public Function ToXml() As String
C#
public string ToXml()

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members
Overload List


%%PageItemTitle%% $$Properties$$

ContentObjectBase Class Properties
[image]
ContentXXL.Content Namespace : ContentObjectBase Class

For a list of all members of this type, see ContentObjectBase members.

Public Properties

 | Name | Description
Public Property | FilterStandardLanguage | Gets or sets a value indicating whether 'Enable Language filter' (module setting) is active.
Public Property | IsBufferValid | Gets a value indicating whether this instance can fetched from buffer (paste operation).
Public Property | IsInPresentationLayer | Gets or sets a value indicating whether this instance is in presentation layer.
Top

See Also

Reference

ContentObjectBase Class
ContentXXL.Content Namespace


%%PageItemTitle%%

FilterStandardLanguage Property
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : FilterStandardLanguage Property

Gets or sets a value indicating whether 'Enable Language filter' (module setting) is active.

Syntax

Visual Basic (Declaration)
Public Property FilterStandardLanguage As Boolean
C#
public bool FilterStandardLanguage {get; set;}

Return Value

true if 'Enable Language filter' is active; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

IsBufferValid Property
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : IsBufferValid Property

Gets a value indicating whether this instance can fetched from buffer (paste operation).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsBufferValid As Boolean
C#
public bool IsBufferValid {get;}

Return Value

true if this instance can be fetched from buffer; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

IsInPresentationLayer Property
[image]
ContentXXL.Content Namespace > ContentObjectBase Class : IsInPresentationLayer Property

Gets or sets a value indicating whether this instance is in presentation layer.

Syntax

Visual Basic (Declaration)
Public Property IsInPresentationLayer As Boolean
C#
public bool IsInPresentationLayer {get; set;}

Return Value

true if this instance is in presentation layer; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBase Class
ContentObjectBase Members


%%PageItemTitle%%

ContentObjectBaseExtended Class
See Also Members
[image]
ContentXXL.Content Namespace : ContentObjectBaseExtended Class

This class is inherited from the ContentObjectBase class and provides a set of properties to access additional database fields.

Syntax

Visual Basic (Declaration)
Public MustInherit Class ContentObjectBaseExtended
   Inherits ContentObjectBase
C#
public abstract class ContentObjectBaseExtended : ContentObjectBase

Inheritance Hierarchy

ContentXXL.Content.ContentObjectBase
ContentXXL.Content.ContentObjectBaseExtended

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBaseExtended Members
ContentXXL.Content Namespace


%%PageItemTitle%% $$Members$$

ContentObjectBaseExtended Class Members
See Also Properties Methods
[image]
ContentXXL.Content Namespace : ContentObjectBaseExtended Class

The following tables list the members exposed by ContentObjectBaseExtended.

Public Properties

 | Name | Description
Public Property | FilterStandardLanguage | Gets or sets a value indicating whether 'Enable Language filter' (module setting) is active. (Inherited from ContentObjectBase)
Public Property | IsBufferValid | Gets a value indicating whether this instance can fetched from buffer (paste operation). (Inherited from ContentObjectBase)
Public Property | IsInPresentationLayer | Gets or sets a value indicating whether this instance is in presentation layer. (Inherited from ContentObjectBase)
Public Property | userdate1 | Gets or sets the userdate1 field.
Public Property | userdate2 | Gets or sets the userdate2 field.
Public Property | userfloat1 | Gets or sets the userfloat1 field.
Public Property | userfloat2 | Gets or sets the userfloat2 field.
Public Property | userfloat3 | Gets or sets the userfloat3 field.
Public Property | userfloat4 | Gets or sets the userfloat4 field.
Public Property | userfloat5 | Gets or sets the userfloat5 field.
Public Property | userimage1 | Gets or sets the userimage1 field.
Public Property | userimage1_alt | Gets or sets the userimage1_alt field.
Public Property | userimage2 | Gets or sets the userimage2 field.
Public Property | userimage2_alt | Gets or sets the userimage2_alt field.
Public Property | userimage3 | Gets or sets the userimage3 field.
Public Property | userimage3_alt | Gets or sets the userimage3_alt field.
Public Property | userimage4 | Gets or sets the userimage4 field.
Public Property | userimage4_alt | Gets or sets the userimage4_alt field.
Public Property | userimage5 | Gets or sets the userimage5 field.
Public Property | userimage5_alt | Gets or sets the userimage5_alt field.
Public Property | userint1 | Gets or sets the userint1 field.
Public Property | userint2 | Gets or sets the userint2 field.
Public Property | userint3 | Gets or sets the userint3 field.
Public Property | userint4 | Gets or sets the userint4 field.
Public Property | userint5 | Gets or sets the userint5 field.
Public Property | UserSetting10 | Gets or sets the usersetting10 field.
Public Property | UserSetting6 | Gets or sets the usersetting6 field.
Public Property | UserSetting7 | Gets or sets the usersetting7 field.
Public Property | UserSetting8 | Gets or sets the usersetting8 field.
Public Property | UserSetting9 | Gets or sets the usersetting9 field.
Top

Public Methods

 | Name | Description
Public Method | CanCreate | Determines whether the current user has create rights the specified module. (Inherited from ContentObjectBase)
Public Method | Copy | Copies this instance to a session variable. (Inherited from ContentObjectBase)
static (Shared in Visual Basic) | CreateInstance | Overloaded. Creates an instance of an object. (Inherited from ContentObjectBase)
static (Shared in Visual Basic) | CreateInstanceByModuleDefID | Creates an instance of a new object (an object which not yet exists in the database) in the context of the specified ModuleDefID. (Inherited from ContentObjectBase)
Public Method | GetAllPublishedObjects | Gets all objects published in the specified module. (Inherited from ContentObjectBase)
Public Method | GetAssigmentsForResource | Gets all objects assigned to the specified resource in the ResourceAssign table. (Inherited from ContentObjectBase)
Public Method | getauthor | Gets the author of this instance. (Inherited from ContentObjectBase)
Public Method | GetByCategoryID | Gets all objects assigned to the specified categoryID with option to filter for objecttype. (Inherited from ContentObjectBase)
Public Method | GetByCategoryRelated | Overloaded. (Inherited from ContentObjectBase)
Public Method | GetByModuleID | Overloaded. Gets all objects belonging to the specified module and published. (Inherited from ContentObjectBase)
Public Method | GetByModuleIDForTeaserView | Gets all objects available for teaser few mode in the specified module (published in a second module). (Inherited from ContentObjectBase)
Public Method | GetByModuleIDXml | Gets all objects belonging to the specified module and published. (Inherited from ContentObjectBase)
Public Method | GetByUrlCategoryIDsAND | Gets all objects assigned to the all categoryIDs in the specified list of categories with option to filter for objecttype. (Inherited from ContentObjectBase)
Public Method | GetByUrlCategoryIDsOR | Gets all objects assigned to the one categoryID in the specified list of categories with option to filter for objecttype. (Inherited from ContentObjectBase)
Public Method | getkeywords | Gets the keywords of this instance. (Inherited from ContentObjectBase)
Public Method | GetManuallyRelated | Overloaded. Gets all objects which are manually related to the specified object. (Inherited from ContentObjectBase)
Public Method | GetManuallyRelatedForWholeModule | Gets all objects which are manually related to the specified module with option to filter for the specified object type and relation type. (Inherited from ContentObjectBase)
Public Method | GetModuleDefID | Gets the ModuleDefinitionID. (Inherited from ContentObjectBase)
Public Method | GetNotPublished | Gets the objects which are not published. (Inherited from ContentObjectBase)
Public Method | GetObjectEditManagerLink | Overloaded. Gets the link to the Object Edit Manager for the current object instance. (Inherited from ContentObjectBase)
Public Method | getpreview | Gets the preview of this instance. (Inherited from ContentObjectBase)
Public Method | GetSingleViewTable | Gets the single view datatable. (Inherited from ContentObjectBase)
Public Method | GetSingleViewTableForPreview | Gets the single view datatable for preview. (Inherited from ContentObjectBase)
Public Method | gettitle | Gets the title of this instance. (Inherited from ContentObjectBase)
Public Method | Paste | Overloaded. Pastes this instance from a session variable. (Inherited from ContentObjectBase)
Public Method | PublishWithPublishRule | Publishes the current instance applying the publishrule of the specified module. (Inherited from ContentObjectBase)
Public Method | Save | Overloaded. Sets the module context to lModuleID and calls the save method of the base class. (Inherited from ContentObjectBase)
Public Method | Search | Overloaded. (Inherited from ContentObjectBase)
Public Method | ToXml | Overloaded. (Inherited from ContentObjectBase)
Top

See Also

Reference

ContentObjectBaseExtended Class
ContentXXL.Content Namespace


%%PageItemTitle%% $$Properties$$

ContentObjectBaseExtended Class Properties
[image]
ContentXXL.Content Namespace : ContentObjectBaseExtended Class

For a list of all members of this type, see ContentObjectBaseExtended members.

Public Properties

 | Name | Description
Public Property | FilterStandardLanguage | Gets or sets a value indicating whether 'Enable Language filter' (module setting) is active. (Inherited from ContentObjectBase)
Public Property | IsBufferValid | Gets a value indicating whether this instance can fetched from buffer (paste operation). (Inherited from ContentObjectBase)
Public Property | IsInPresentationLayer | Gets or sets a value indicating whether this instance is in presentation layer. (Inherited from ContentObjectBase)
Public Property | userdate1 | Gets or sets the userdate1 field.
Public Property | userdate2 | Gets or sets the userdate2 field.
Public Property | userfloat1 | Gets or sets the userfloat1 field.
Public Property | userfloat2 | Gets or sets the userfloat2 field.
Public Property | userfloat3 | Gets or sets the userfloat3 field.
Public Property | userfloat4 | Gets or sets the userfloat4 field.
Public Property | userfloat5 | Gets or sets the userfloat5 field.
Public Property | userimage1 | Gets or sets the userimage1 field.
Public Property | userimage1_alt | Gets or sets the userimage1_alt field.
Public Property | userimage2 | Gets or sets the userimage2 field.
Public Property | userimage2_alt | Gets or sets the userimage2_alt field.
Public Property | userimage3 | Gets or sets the userimage3 field.
Public Property | userimage3_alt | Gets or sets the userimage3_alt field.
Public Property | userimage4 | Gets or sets the userimage4 field.
Public Property | userimage4_alt | Gets or sets the userimage4_alt field.
Public Property | userimage5 | Gets or sets the userimage5 field.
Public Property | userimage5_alt | Gets or sets the userimage5_alt field.
Public Property | userint1 | Gets or sets the userint1 field.
Public Property | userint2 | Gets or sets the userint2 field.
Public Property | userint3 | Gets or sets the userint3 field.
Public Property | userint4 | Gets or sets the userint4 field.
Public Property | userint5 | Gets or sets the userint5 field.
Public Property | UserSetting10 | Gets or sets the usersetting10 field.
Public Property | UserSetting6 | Gets or sets the usersetting6 field.
Public Property | UserSetting7 | Gets or sets the usersetting7 field.
Public Property | UserSetting8 | Gets or sets the usersetting8 field.
Public Property | UserSetting9 | Gets or sets the usersetting9 field.
Top

See Also

Reference

ContentObjectBaseExtended Class
ContentXXL.Content Namespace


%%PageItemTitle%%

userdate1 Property
[image]
ContentXXL.Content Namespace > ContentObjectBaseExtended Class : userdate1 Property

Gets or sets the userdate1 field.

Syntax

Visual Basic (Declaration)
Public Property userdate1 As Date
C#
public DateTime userdate1 {get; set;}

Return Value

The userdate1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBaseExtended Class
ContentObjectBaseExtended Members


%%PageItemTitle%%

userdate2 Property
[image]
ContentXXL.Content Namespace > ContentObjectBaseExtended Class : userdate2 Property

Gets or sets the userdate2 field.

Syntax

Visual Basic (Declaration)
Public Property userdate2 As Date
C#
public DateTime userdate2 {get; set;}

Return Value

The userdate2.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBaseExtended Class
ContentObjectBaseExtended Members


%%PageItemTitle%%

userfloat1 Property
[image]
ContentXXL.Content Namespace > ContentObjectBaseExtended Class : userfloat1 Property

Gets or sets the userfloat1 field.

Syntax

Visual Basic (Declaration)
Public Property userfloat1 As Double
C#
public double userfloat1 {get; set;}

Return Value

The userfloat1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBaseExtended Class
ContentObjectBaseExtended Members


%%PageItemTitle%%

userfloat2 Property
[image]
ContentXXL.Content Namespace > ContentObjectBaseExtended Class : userfloat2 Property

Gets or sets the userfloat2 field.

Syntax

Visual Basic (Declaration)
Public Property userfloat2 As Double
C#
public double userfloat2 {get; set;}

Return Value

The userfloat2.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBaseExtended Class
ContentObjectBaseExtended Members


%%PageItemTitle%%

userfloat3 Property
[image]
ContentXXL.Content Namespace > ContentObjectBaseExtended Class : userfloat3 Property

Gets or sets the userfloat3 field.

Syntax

Visual Basic (Declaration)
Public Property userfloat3 As Double
C#
public double userfloat3 {get; set;}

Return Value

The userfloat3.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBaseExtended Class
ContentObjectBaseExtended Members


%%PageItemTitle%%

userfloat4 Property
[image]
ContentXXL.Content Namespace > ContentObjectBaseExtended Class : userfloat4 Property

Gets or sets the userfloat4 field.

Syntax

Visual Basic (Declaration)
Public Property userfloat4 As Double
C#
public double userfloat4 {get; set;}

Return Value

The userfloat4.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBaseExtended Class
ContentObjectBaseExtended Members


%%PageItemTitle%%

userfloat5 Property
[image]
ContentXXL.Content Namespace > ContentObjectBaseExtended Class : userfloat5 Property

Gets or sets the userfloat5 field.

Syntax

Visual Basic (Declaration)
Public Property userfloat5 As Double
C#
public double userfloat5 {get; set;}

Return Value

The userfloat5.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBaseExtended Class
ContentObjectBaseExtended Members


%%PageItemTitle%%

userimage1 Property
[image]
ContentXXL.Content Namespace > ContentObjectBaseExtended Class : userimage1 Property

Gets or sets the userimage1 field.

Syntax

Visual Basic (Declaration)
Public Property userimage1 As Integer
C#
public int userimage1 {get; set;}

Return Value

The userimage1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBaseExtended Class
ContentObjectBaseExtended Members


%%PageItemTitle%%

userimage1_alt Property
[image]
ContentXXL.Content Namespace > ContentObjectBaseExtended Class : userimage1_alt Property

Gets or sets the userimage1_alt field.

Syntax

Visual Basic (Declaration)
Public Property userimage1_alt As String
C#
public string userimage1_alt {get; set;}

Return Value

The userimage1_alt.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBaseExtended Class
ContentObjectBaseExtended Members


%%PageItemTitle%%

userimage2 Property
[image]
ContentXXL.Content Namespace > ContentObjectBaseExtended Class : userimage2 Property

Gets or sets the userimage2 field.

Syntax

Visual Basic (Declaration)
Public Property userimage2 As Integer
C#
public int userimage2 {get; set;}

Return Value

The userimage2.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBaseExtended Class
ContentObjectBaseExtended Members


%%PageItemTitle%%

userimage2_alt Property
[image]
ContentXXL.Content Namespace > ContentObjectBaseExtended Class : userimage2_alt Property

Gets or sets the userimage2_alt field.

Syntax

Visual Basic (Declaration)
Public Property userimage2_alt As String
C#
public string userimage2_alt {get; set;}

Return Value

The userimage2_alt.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBaseExtended Class
ContentObjectBaseExtended Members


%%PageItemTitle%%

userimage3 Property
[image]
ContentXXL.Content Namespace > ContentObjectBaseExtended Class : userimage3 Property

Gets or sets the userimage3 field.

Syntax

Visual Basic (Declaration)
Public Property userimage3 As Integer
C#
public int userimage3 {get; set;}

Return Value

The userimage3.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBaseExtended Class
ContentObjectBaseExtended Members


%%PageItemTitle%%

userimage3_alt Property
[image]
ContentXXL.Content Namespace > ContentObjectBaseExtended Class : userimage3_alt Property

Gets or sets the userimage3_alt field.

Syntax

Visual Basic (Declaration)
Public Property userimage3_alt As String
C#
public string userimage3_alt {get; set;}

Return Value

The userimage3_alt.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBaseExtended Class
ContentObjectBaseExtended Members


%%PageItemTitle%%

userimage4 Property
[image]
ContentXXL.Content Namespace > ContentObjectBaseExtended Class : userimage4 Property

Gets or sets the userimage4 field.

Syntax

Visual Basic (Declaration)
Public Property userimage4 As Integer
C#
public int userimage4 {get; set;}

Return Value

The userimage4.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBaseExtended Class
ContentObjectBaseExtended Members


%%PageItemTitle%%

userimage4_alt Property
[image]
ContentXXL.Content Namespace > ContentObjectBaseExtended Class : userimage4_alt Property

Gets or sets the userimage4_alt field.

Syntax

Visual Basic (Declaration)
Public Property userimage4_alt As String
C#
public string userimage4_alt {get; set;}

Return Value

The userimage4_alt.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBaseExtended Class
ContentObjectBaseExtended Members


%%PageItemTitle%%

userimage5 Property
[image]
ContentXXL.Content Namespace > ContentObjectBaseExtended Class : userimage5 Property

Gets or sets the userimage5 field.

Syntax

Visual Basic (Declaration)
Public Property userimage5 As Integer
C#
public int userimage5 {get; set;}

Return Value

The userimage5.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBaseExtended Class
ContentObjectBaseExtended Members


%%PageItemTitle%%

userimage5_alt Property
[image]
ContentXXL.Content Namespace > ContentObjectBaseExtended Class : userimage5_alt Property

Gets or sets the userimage5_alt field.

Syntax

Visual Basic (Declaration)
Public Property userimage5_alt As String
C#
public string userimage5_alt {get; set;}

Return Value

The userimage5_alt.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBaseExtended Class
ContentObjectBaseExtended Members


%%PageItemTitle%%

userint1 Property
[image]
ContentXXL.Content Namespace > ContentObjectBaseExtended Class : userint1 Property

Gets or sets the userint1 field.

Syntax

Visual Basic (Declaration)
Public Property userint1 As Integer
C#
public int userint1 {get; set;}

Return Value

The userint1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBaseExtended Class
ContentObjectBaseExtended Members


%%PageItemTitle%%

userint2 Property
[image]
ContentXXL.Content Namespace > ContentObjectBaseExtended Class : userint2 Property

Gets or sets the userint2 field.

Syntax

Visual Basic (Declaration)
Public Property userint2 As Integer
C#
public int userint2 {get; set;}

Return Value

The userint2.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBaseExtended Class
ContentObjectBaseExtended Members


%%PageItemTitle%%

userint3 Property
[image]
ContentXXL.Content Namespace > ContentObjectBaseExtended Class : userint3 Property

Gets or sets the userint3 field.

Syntax

Visual Basic (Declaration)
Public Property userint3 As Integer
C#
public int userint3 {get; set;}

Return Value

The userint3.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBaseExtended Class
ContentObjectBaseExtended Members


%%PageItemTitle%%

userint4 Property
[image]
ContentXXL.Content Namespace > ContentObjectBaseExtended Class : userint4 Property

Gets or sets the userint4 field.

Syntax

Visual Basic (Declaration)
Public Property userint4 As Integer
C#
public int userint4 {get; set;}

Return Value

The userint4.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBaseExtended Class
ContentObjectBaseExtended Members


%%PageItemTitle%%

userint5 Property
[image]
ContentXXL.Content Namespace > ContentObjectBaseExtended Class : userint5 Property

Gets or sets the userint5 field.

Syntax

Visual Basic (Declaration)
Public Property userint5 As Integer
C#
public int userint5 {get; set;}

Return Value

The userint5.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBaseExtended Class
ContentObjectBaseExtended Members


%%PageItemTitle%%

UserSetting10 Property
[image]
ContentXXL.Content Namespace > ContentObjectBaseExtended Class : UserSetting10 Property

Gets or sets the usersetting10 field.

Syntax

Visual Basic (Declaration)
Public Property UserSetting10 As String
C#
public string UserSetting10 {get; set;}

Return Value

The user setting10.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBaseExtended Class
ContentObjectBaseExtended Members


%%PageItemTitle%%

UserSetting6 Property
[image]
ContentXXL.Content Namespace > ContentObjectBaseExtended Class : UserSetting6 Property

Gets or sets the usersetting6 field.

Syntax

Visual Basic (Declaration)
Public Property UserSetting6 As String
C#
public string UserSetting6 {get; set;}

Return Value

The user setting6.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBaseExtended Class
ContentObjectBaseExtended Members


%%PageItemTitle%%

UserSetting7 Property
[image]
ContentXXL.Content Namespace > ContentObjectBaseExtended Class : UserSetting7 Property

Gets or sets the usersetting7 field.

Syntax

Visual Basic (Declaration)
Public Property UserSetting7 As String
C#
public string UserSetting7 {get; set;}

Return Value

The user setting7.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBaseExtended Class
ContentObjectBaseExtended Members


%%PageItemTitle%%

UserSetting8 Property
[image]
ContentXXL.Content Namespace > ContentObjectBaseExtended Class : UserSetting8 Property

Gets or sets the usersetting8 field.

Syntax

Visual Basic (Declaration)
Public Property UserSetting8 As String
C#
public string UserSetting8 {get; set;}

Return Value

The user setting8.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBaseExtended Class
ContentObjectBaseExtended Members


%%PageItemTitle%%

UserSetting9 Property
[image]
ContentXXL.Content Namespace > ContentObjectBaseExtended Class : UserSetting9 Property

Gets or sets the usersetting9 field.

Syntax

Visual Basic (Declaration)
Public Property UserSetting9 As String
C#
public string UserSetting9 {get; set;}

Return Value

The user setting9.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentObjectBaseExtended Class
ContentObjectBaseExtended Members


%%phrase%%

contentXXL Assembly

Namespaces

Namespace | Description
ContentXXL.Content |


$$GETTING_STARTED$$ - %%projecttitle%%

Getting Started


$$INTRODUCTION$$ - %%projecttitle%%

Introduction


%%PageItemTitle%% $$Methods$$

ContentObjectBaseExtended Class Methods
[image]
ContentXXL.Content Namespace : ContentObjectBaseExtended Class

For a list of all members of this type, see ContentObjectBaseExtended members.

Public Methods

 | Name | Description
Public Method | CanCreate | Determines whether the current user has create rights the specified module. (Inherited from ContentObjectBase)
Public Method | Copy | Copies this instance to a session variable. (Inherited from ContentObjectBase)
static (Shared in Visual Basic) | CreateInstance | Overloaded. Creates an instance of an object. (Inherited from ContentObjectBase)
static (Shared in Visual Basic) | CreateInstanceByModuleDefID | Creates an instance of a new object (an object which not yet exists in the database) in the context of the specified ModuleDefID. (Inherited from ContentObjectBase)
Public Method | GetAllPublishedObjects | Gets all objects published in the specified module. (Inherited from ContentObjectBase)
Public Method | GetAssigmentsForResource | Gets all objects assigned to the specified resource in the ResourceAssign table. (Inherited from ContentObjectBase)
Public Method | getauthor | Gets the author of this instance. (Inherited from ContentObjectBase)
Public Method | GetByCategoryID | Gets all objects assigned to the specified categoryID with option to filter for objecttype. (Inherited from ContentObjectBase)
Public Method | GetByCategoryRelated | Overloaded. (Inherited from ContentObjectBase)
Public Method | GetByModuleID | Overloaded. Gets all objects belonging to the specified module and published. (Inherited from ContentObjectBase)
Public Method | GetByModuleIDForTeaserView | Gets all objects available for teaser few mode in the specified module (published in a second module). (Inherited from ContentObjectBase)
Public Method | GetByModuleIDXml | Gets all objects belonging to the specified module and published. (Inherited from ContentObjectBase)
Public Method | GetByUrlCategoryIDsAND | Gets all objects assigned to the all categoryIDs in the specified list of categories with option to filter for objecttype. (Inherited from ContentObjectBase)
Public Method | GetByUrlCategoryIDsOR | Gets all objects assigned to the one categoryID in the specified list of categories with option to filter for objecttype. (Inherited from ContentObjectBase)
Public Method | getkeywords | Gets the keywords of this instance. (Inherited from ContentObjectBase)
Public Method | GetManuallyRelated | Overloaded. Gets all objects which are manually related to the specified object. (Inherited from ContentObjectBase)
Public Method | GetManuallyRelatedForWholeModule | Gets all objects which are manually related to the specified module with option to filter for the specified object type and relation type. (Inherited from ContentObjectBase)
Public Method | GetModuleDefID | Gets the ModuleDefinitionID. (Inherited from ContentObjectBase)
Public Method | GetNotPublished | Gets the objects which are not published. (Inherited from ContentObjectBase)
Public Method | GetObjectEditManagerLink | Overloaded. Gets the link to the Object Edit Manager for the current object instance. (Inherited from ContentObjectBase)
Public Method | getpreview | Gets the preview of this instance. (Inherited from ContentObjectBase)
Public Method | GetSingleViewTable | Gets the single view datatable. (Inherited from ContentObjectBase)
Public Method | GetSingleViewTableForPreview | Gets the single view datatable for preview. (Inherited from ContentObjectBase)
Public Method | gettitle | Gets the title of this instance. (Inherited from ContentObjectBase)
Public Method | Paste | Overloaded. Pastes this instance from a session variable. (Inherited from ContentObjectBase)
Public Method | PublishWithPublishRule | Publishes the current instance applying the publishrule of the specified module. (Inherited from ContentObjectBase)
Public Method | Save | Overloaded. Sets the module context to lModuleID and calls the save method of the base class. (Inherited from ContentObjectBase)
Public Method | Search | Overloaded. (Inherited from ContentObjectBase)
Public Method | ToXml | Overloaded. (Inherited from ContentObjectBase)
Top

See Also

Reference

ContentObjectBaseExtended Class
ContentXXL.Content Namespace